Como instalar: plugin do Flash + Firefox + AMD 64 Bits no Linux

Atualmente é grande o número de sites que utilizam flash, portanto instalar um plugin para o seu navegador é essencial.

Aqui vou mostrar como fazê-lo para o Firefox no Linux (Ubuntu).

Este tutorial, foi feito e testado no Ubuntu 7.10 64 Bits, utilizando o Firefox 2.0.0.6 64 Bits e o Adobe Flash Player de 32 bits.

Quando você abre uma página que precise de flash, o Firefox avisará e lhe dará as seguintes opções: gnash e adobe flash player.

Embora possa se usar o gnash, apenas habilitando as atualizações pré-liberadas no Gerenciador de Pacotes Synaptic e mandando instalar por lá, não fiquei satisfeito com o resultado, pois o programa veio com alguns bugs em sites, como o Youtube.

Resolvi, então, instalar o Flash Player da Adobe.

Para quem usa a versão de 32 bits, faça o download do arquivo compactado, diretamente do site da Adobe e siga as instruções de lá. Teoricamente funcionará, mas eu não testei.

Para quem usa a versão de 64 bits, é preciso fazer uma gambiarra, usando o programa nspluginwrapper.
  1. Instale o nspluginwrapper. Li bastante sobre isso, falando sobre atualizar repositórios e dar sudo apt-get install nspluginwrapper, mas o que funcionou, na verdade, foi fazer o download do arquivo nspluginwrapper_0.9.91.5-1ubuntu1_amd64.deb e instalá-lo.
  2. Baixe o Adobe Flash Player de 32 bit mesmo, o mesmo de lá de cima.
  3. Descompacte o conteúdo em uma pasta.
    Copie o conteúdo da pasta para /usr/lib/nspluginwrapper/plugins/.
    sudo cp install_flash_player_9_linux/* /usr/lib/nspluginwrapper/plugins/
    Rode o comando:
    nspluginwrapper -i /usr/lib/nspluginwrapper/plugins/libflashplayer.so
  4. Pronto, reinicie seu browser e o Flash já estará totalmente funcional no seu Ubuntu 64 Bit’s.
Parece que, a cada vez que atualizar o Firefox, será preciso executar sudo nspluginwrapper -v -a -i ou nspluginwrapper -v -a -u para o plugin voltar a funcionar, mas isso eu também não testei.

Para quem não sabe como descompactar arquivos, instalar um arquivo .deb ou onde deve digitar os comandos, sugiro ler alguns manuais básicos de Linux ou chamar alguém que saiba.

Fontes:
Blog do Cleuby
Javintus Blog & Repository
Blog do Helio
Documentação do Ubuntu

Atualização (23/05/2008):
Para instalar na versão 8.04 do Ubuntu 64 bits, basta ir em Administração/Gerenciador de Pacotes Synaptic, procurar por flashplugin-nonfree, marcar para instalar e clicar em aplicar.

Em Canais de software, aba Programas do Ubuntu, talvez seja necessário habilitar os quatro primeiros itens.

Que bom que as coisas evoluem!

Comentários

Postagens mais visitadas